Haruyuki Mohri

毛利春幸のブログです。

Android Duplicate id @+id/image, already defined earlier in this layout

Duplicate id @+id/image, already defined earlier in this layout

Eclipseで上記のようなエラーが出た場合

f:id:mojeld:20150225180907p:plain

 

Android Lint Preferencesの項目

DuplicateIdsとInstantiatableをWarningに変更して回避する

f:id:mojeld:20150225181435j:plain

 ついでに「ble requires API level 21 」こんなエラーも出るので

f:id:mojeld:20150225181857p:plain

あまり良い方法では無いのか不明。